Announcement

Collapse
No announcement yet.

Pro Flo XT Plus ECU Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pro Flo XT Plus ECU Problem

    Just received my ECU back from Edelbrock that flashed it back to original. While following the quick start guide I updated the firmware to the 71R_01_8CYL.FSX. After it uploading to the ECU it will not show any information to the eflash diagnostics page and the system editor wont display fuel pressure or Battery voltage. Once the ECU is powered on the fuel pump wont stop running. Any help would be appreciated. I have yet to get this system to run with my 68 Camaro with a SBC.

  • #2
    You are using a distributor?

    I wonder if some one put the wrong label on the back of the ECU.
    Could you post a picture of the label on the front of the ECU?
    At 43,861 MPH Elon Musk now owns the fastest car in this Galaxy

    Comment


    • #3
      Could you also refer me to if I wanted to buy the pro flo 4 computer and harness how much it would be cause I have had so many issues with the system.
      Attached Files

      Comment


      • #4
        That is a Pro-Flo XT Plus, and your first post is the correct firmware.
        So I don't know why it's not working.
        Might be in the wiring?

        Your better off getting the Pro-Flo 4, whole kit. Piecing it together costs the same.
        At 43,861 MPH Elon Musk now owns the fastest car in this Galaxy

        Comment

        Working...
        X