Announcement

Collapse
No announcement yet.

Throttle body base gasket part number for 35760

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Throttle body base gasket part number for 35760

    Hello, Does anyone know part number for throttle body base gasket on kit #35760 for SBC
    Chevy?

  • #2
    If you are referring to something like this, https://www.autozone.com/fuel-delive...B&gclsrc=aw.ds , you should be able to just walk into your local auto parts store and buy it. It's just a standard carb basplate gasket.

    Comment


    • #3
      Yeah I found a Fel Pro 1900 and installed. Did not solve my problem. I have had to progressively turn idle screw out to lower my rpm to 900rpm over the past few months to the point that throttle blades were completely closed and still idling over 950. IAC has been reading 0 also. Figured I had a leaking base plate gasket. My vacumm has stayed consistently at 17.6 at idle for the past 4 months though. So I took my Wagner PCV Valve off and reinstalled stock PCV Valve. Helped enough that I can get it to idle at 900, but my throttle blades are closed. Idle screw not even touching throttle arm. And I have throttle cable completely unhooked also to eliminate that. I know throttle blades are closed because I have physically looked at them while engine running. IAC is reading 1-3. My TPS has always read 0 at idle for the past 3 years. Im wondering if IAC could be defective and raising my idle and not giving a reading.
      Last edited by Stryker; 07-17-2021, 10:18 AM.

      Comment


      • #4
        Could be lots of things why idle is high with closed throttle blades.

        Did you use the intake gaskets that came with the kit?

        Did you use Gasgacinch when you installed the gaskets?

        Did you use thread sealant on the intake bolts?

        Have you plugged all vacuum ports to see if you have a leaking vacuum modulator, brake booster, or heater controls?

        Is the IAC's chamber clear of all carbon deposits?
        In my neighborhood, if you open your hood to check your oil, and the vehicle still runs after you close it.......Then your labeled the Neighborhood Mechanic.
        https://forums.edelbrock.com/filedat...?photoid=42773

        Comment


        • #5
          Originally posted by BITE_ME View Post
          Could be lots of things why idle is high with closed throttle blades.

          Did you use the intake gaskets that came with the kit?

          Did you use Gasgacinch when you installed the gaskets?

          Did you use thread sealant on the intake bolts?

          Have you plugged all vacuum ports to see if you have a leaking vacuum modulator, brake booster, or heater controls?

          Is the IAC's chamber clear of all carbon deposits?
          Yes on Gaskets, Gasgacinch, and thread sealant.
          It's Standard transmission and Cable operated heater controls, But I have not plugged off brake booster to check- I will do that
          Im getting a new IAC and will check for carbon deposits when I change it.

          I have always had 17.6 vacumn at idle all along, thats never changed. I have sprayed carb cleaner around intake looking for rpm rise- None.
          For the past 3 months I have noticed idle high and IAC at 0, So I have adjusted idle down with screw and when I get to my target IAC is back near 5 again. I have adjusted it this way at least 10 times in last 3 months. Now blades are closed. I will check brake booster though, it was a refurbished item 3 years ago. All displays numbers have stayed normal except loosing iac help and rpm rising.

          Comment


          • #6
            Originally posted by Stryker View Post
            Hello, Does anyone know part number for throttle body base gasket on kit #35760 for SBC
            Chevy?
            • Edelbrock #3899 (4150) ProFlo 4
            Don't get too caught up in the numbers.
            Just give the Engine what it wants &
            Let the numbers be what they are.

            Jim McFarland....

            Comment


            • #7
              Found the problem, I sprayed brake clean near intake to head flanges and found right side was sucking and evaporating the Brake clean instantianiously . (Not sure why Carb cleaner did not show this). Anyhow the blue printoseal is showing just above intake flange on that side. So I temporarily fill that area in with Ultra gray frogsnot and ordered a .120 thick intake gasket set (Felpro 1266) to replace the .060 1206 set I have on there now. That should bring intake flanges in better alignment with heads. Thanks for everyones help.

              Comment


              • #8
                Did you have the heads trued / milled?

                Comment


                • #9
                  Brand new ATK heads 3 months ago. I own and operate an Engine Rebuilding shop for last 26 years, with my Dad and Uncle in the business since 1956.

                  Comment

                  Working...
                  X