Announcement

Collapse
No announcement yet.

Hard start

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hard start

    Hard starting after turn it off after driving on hot days. After it sits for about ten minutes , then try to start it up. It starts but it idles about 400-500 rpms or I have to press accelerator to start it.

  • #2
    did you adjust the base idle screw ?

    Comment


    • #3
      take a video of the tablet screen when you are having the trouble.

      Comment


      • #4
        Yes , idle is adjusted, I will start to bring tablet a video it. Thanks for the info

        Comment


        • #5
          Originally posted by Galxl68 View Post
          Hard starting after turn it off after driving on hot days. After it sits for about ten minutes , then try to start it up. It starts but it idles about 400-500 rpms or I have to press accelerator to start it.
          I had this problem too since summer temps arrived. I reasoned that the 120 degree air under the hood was thinner than cooler air. It also started quicker if I gave it some throttle while cranking. So, I reasoned it was rich. I reduced the cranking fuel by 10% and Bam! No more hot start issue. Maybe just dumb luck or coincidence but it fixed it.

          Comment


          • #6
            if you are using the tablet that came in the kit it has an app on it start the video app then start the edelbrock pro-flo app then start recording

            Comment

            Working...
            X