Announcement

Collapse
No announcement yet.

65 El Camino won’t turn off

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 65 El Camino won’t turn off

    I have a original 65 El Camino w/ 327. All original wiring, and charging system. Freshly installed PF4. Everything seams to be wired properly and engine is running great. Only problem I have is that the truck won’t shut off after the key is turned back to the off position.

  • #2
    How close is the ECU to the Dist ?
    Dakota digital gauges ?

    Call the Tech line 800-416-8628
    Don't get too caught up in the numbers.
    Just give the Engine what it wants &
    Let the numbers be what they are.

    Jim McFarland....

    Comment


    • #3
      ECU is mounted in the fender well a couple feet away

      Comment


      • #4
        Stock dash and gauges

        Comment


        • #5
          How many wire s connected at the coil ?
          Don't get too caught up in the numbers.
          Just give the Engine what it wants &
          Let the numbers be what they are.

          Jim McFarland....

          Comment


          • #6
            Currently just the two from the PF4. One to the + side and one to the - side as per the instructions. I wasn’t sure if I’m supposed to reuse any of the original wires that we wired to the old coil or not.

            Comment


            • #7
              Jumper the Pink/Black ign key 12v wire to the battery + post ---for testing----- will it turn off when removed ?
              Don't get too caught up in the numbers.
              Just give the Engine what it wants &
              Let the numbers be what they are.

              Jim McFarland....

              Comment


              • #8
                I’m not in front of the truck right now. I’ll give that a try. I know that when my key is off my gen/alt light on my dash comes on and stays on while the truck continues to run. I’ve been removing a wire from the alt to get the truck to turn off or disconnect a battery cable.

                Comment


                • #9
                  https://forums.edelbrock.com/forum/p...0%99t-shut-off

                  Don't get too caught up in the numbers.
                  Just give the Engine what it wants &
                  Let the numbers be what they are.

                  Jim McFarland....

                  Comment


                  • #10
                    so there is a back feed in the power supply . where did you get the power for fuel pump and pink /black ?

                    Comment


                    • #11
                      I used the Edlebrock really harness that plugs directly in to the fuel pump harness and connected the power to the positive side of the battery.

                      Comment


                      • #12
                        Sorry forgot to answer the second question. The pink/black ignition wire is connected to a wire that I have ran from the fused ignition terminal on the fuse panel in the cab of the truck.

                        Comment


                        • #13
                          ok the fuel pump harness is a supply for the pump. where did you hook the +12 volt wire for e c u to ? if hooked to a wire that is feed to alt it could back feed to keep it running. do as cast said when you get the time.

                          Comment


                          • #14
                            The ECU power is connected to the battery.

                            Comment


                            • #15
                              With the key off and the engine still running, disconnect the 2 wire connector at the top of the Alt. If the motor stops install a diode in the small wire (usually brown). This is the wire that goes to the "idiot" light in the dash. 99.8% effective cure for your issue.
                              Last edited by R573CAR; 06-11-2021, 01:49 PM.

                              Comment

                              Working...
                              X