Announcement

Collapse
No announcement yet.

Squealing during Acceleration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by CMerchant View Post
    2700Cast - anything to add? is my IAC just not set properly and that's it?
    Have you located the source of your noise ?

    How many miles have you put on the PF4 ?
    Don't get too caught up in the numbers.
    Just give the Engine what it wants &
    Let the numbers be what they are.

    Jim McFarland....

    Comment


    • #17
      Originally posted by CMerchant View Post
      2700Cast - anything to add? is my IAC just not set properly and that's it?
      Thats a question that can only be answered by actually doing it.
      In my neighborhood, if you open your hood to check your oil, and the vehicle still runs after you close it.......Then your labeled the Neighborhood Mechanic.
      https://forums.edelbrock.com/filedat...?photoid=42773

      Comment


      • #18
        Originally posted by 2700 Cast View Post

        Have you located the source of your noise ?

        How many miles have you put on the PF4 ?
        The...engine? it's really hard to say where it's coming from but it's not the serpentine belt or the pulleys.

        Probably 1000 miles on the system so far. Are you suggesting it will tune itself out?

        Comment


        • #19
          I'm not trying to be crack wise here at all. The only time my engine squealed was due to a V belt issue, and after that was taken care of there were no other issues.

          Comment


          • #20
            for a test turn the idle screw up 1 to 2 turns and see if the noise changes. i have had i a c valves make some wired noises with the air flow

            Comment

            Working...
            X