Announcement

Collapse
No announcement yet.

Help with PF4 Several Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with PF4 Several Issues

    Hello,

    I have had the PF4 installed for roughly 3 weeks or so, and have approximately 15 miles on the setup. The car runs BORDERLINE decent, but I'm having multiple issues. It's an aluminum headed BBC 496 10.5:1. race profile cam (according to Edelbrock's setup wizard.)
    It seems that it is EXTREMELY lazy off idle in comparison to the poorly tuned carb I had on previously. easy throttle input, or aggressive throttle input.

    Additionally, the car backfires on deceleration about 95% of the time, almost like it's lean popping thru the exhaust during decel. It's also dieseling upon key-off shutdown. I think I am a little bummed that I spent $2500 on this kit (including the Edelbrock fuel sump pump) , and are having these issues.

    Timing is at 12*
    Idle spark @ 12*
    Advance spark @ 1200 RPM
    Total Spark @ 36*
    Total spark RPM @ 3000 RPM
    Fuel pressure is 58 +/- a PSI or 2

    Should I play with fuel modifiers?
    Acceleration fuel?
    Do I not have enough miles on it for the self learn to be acquainted?

    I feel as if my Escalade is way more powerful from a dead stop than this car. Hell, my 2000 V6 Honda accord will give this thing a run for it's money off the line. I understand that EFI has a few millisecond delay to think about how to disperse fuel and air under given throttle conditions, but I don't think I could spin the tires with the tires soaked in armor all from a stop.


    Any help will be GREATLY appreciated!

  • #2
    What Calibration MAP are you using?

    What type of fuel are you using?

    Could you post a picture of the "Digital Display" at idle, and above idle in gear.
    In my neighborhood, if you open your hood to check your oil, and the vehicle still runs after you close it.......Then your labeled the Neighborhood Mechanic.

    Comment


    • #3
      My experience with this same problem is the Mild Cam map will be much much better.

      Comment


      • #4
        What a name LOL

        Comment


        • #5
          Originally posted by Camel_Toe_Pro View Post
          Hello,

          I have had the PF4 installed for roughly 3 weeks or so, and have approximately 15 miles on the setup. The car runs BORDERLINE decent, but I'm having multiple issues. It's an aluminum headed BBC 496 10.5:1. race profile cam (according to Edelbrock's setup wizard.)
          It seems that it is EXTREMELY lazy off idle in comparison to the poorly tuned carb I had on previously. easy throttle input, or aggressive throttle input.

          Additionally, the car backfires on deceleration about 95% of the time, almost like it's lean popping thru the exhaust during decel. It's also dieseling upon key-off shutdown. I think I am a little bummed that I spent $2500 on this kit (including the Edelbrock fuel sump pump) , and are having these issues.


          Idle spark @ 12*

          With your RACE Cam profile: Bump up your " idle spark " to 22 degrees.
          That will improve your " Laziness".

          Also if still has slight flat spot on take off: bump up " Pump shot " 15% with 5 duration.

          Now go see if that BBC will roar.....If not , then check leakdown & compression.

          Comment


          • #6
            I have my 496 at 22 idle and total at 36. I tryed 36 all the time with no difference. I had mine at 15 idle with success.

            Comment


            • #7
              Sounds like theres a air leak in the exhaust which would lean out the wideband and also would make it backfire on decel. Turn the wideband sensor off and see if it helps. Take your time to tune the system. Fuel injection is different then a carb to tune. If you get frustrated you wont get there. Tuning it right is worth it in the end.
              Last edited by Scselt; 03-30-2020, 03:39 PM.

              Comment


              • #8
                Usually backfiring out the exhaust is a rich condition, unless there is an exhaust leak. What are the air fuel ratios looking like?

                Any chance you have a plug wire crossed, or timing reference off ?

                Comment


                • #9
                  Well gents, I must admit, I was very exhausted and frustrated with this, but the member, and Technician, ***2700 Cast*** has me (deep) in the ballpark. It's still a tad lazier than I'd like, but MUCH better than I had.

                  I think it's down finite tuning and I'll be WAY happier than I was. I thoroughly appreciate everyone's comments and will continue to lean on you guys for advice. Again thank you!

                  Comment


                  • #10
                    Originally posted by 2700 Cast View Post

                    With your RACE Cam profile: Bump up your " idle spark " to 22 degrees.
                    That will improve your " Laziness".

                    Also if still has slight flat spot on take off: bump up " Pump shot " 15% with 5 duration.

                    Now go see if that BBC will roar.....If not , then check leakdown & compression.
                    2700 CAST - 2 things good sir.

                    upping the idle spark to 22 - does this apply to a 400ci SBC as well? mine is lazy as well. 517hp 546lbft. but it feels far less than that. camry's in traffic scare me.

                    And getting the pop on decel. i checked plugs, wires and leaks, and so far nothing stands out. i have about 100 miles on this setup.

                    Comment

                    Working...
                    X