Announcement

Collapse
No announcement yet.

Tps sensot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tps sensot

    Does anyone know what kind of tps sensor we have ?
    I keep having a 1500 rpm hesitation on acceleration. I am leaning on the tps sensor aldough the trottle degree on the handheld is smooth.
    it looks like a tbi tps sensor but it has a different conector.
    496 in a 454SS truck, Pro-flo 2 and "remote 80MM turbo"

  • #2
    The TPS is # 3582.
    Used on Pro-Flo (1), and Pro-Flo 2.

    Also # 36018 was used for above.
    "Do you know how whipped an engine has to be to blow that loud?"....Bug from the movie Uncle Buck
    https://forums.edelbrock.com/filedat...?photoid=42773

    Comment


    • #3
      Thanks,
      why would they change to a new style and conector.
      496 in a 454SS truck, Pro-flo 2 and "remote 80MM turbo"

      Comment


      • #4
        Because the company that makes the TPS, stopped making it......people with fuel injected HD motorcycles have the same issue. Can't get a replacement TPS.

        Fun fact: The connector used on the Pro-Flo 4 ECU, is the same one used on HD motorcycle stereos.

        I believe some one in charge of the EFI systems at Edelbrock liked using the parts of HD motorcycles.
        "Do you know how whipped an engine has to be to blow that loud?"....Bug from the movie Uncle Buck
        https://forums.edelbrock.com/filedat...?photoid=42773

        Comment


        • #5
          • Edelbrock #36018
          • ACDELCO #19322821
          • Standard Products #TH42
          ‚Äč4150 t-body
          Don't get too caught up in the numbers.
          Just give the Engine what it wants &
          Let the numbers be what they are.

          Jim McFarland....

          Comment


          • #6
            I found one for a Moto guzi, looks identical as the edelbrock original, localy
            496 in a 454SS truck, Pro-flo 2 and "remote 80MM turbo"

            Comment


            • #7
              The moto guzi most likely turns the opposite direction.....it needs to turn clockwise when you look at the inside drive section.
              "Do you know how whipped an engine has to be to blow that loud?"....Bug from the movie Uncle Buck
              https://forums.edelbrock.com/filedat...?photoid=42773

              Comment


              • #8
                i use 1999 to 2005 gm holden with ecotec 3.8 litre V6 engine
                i assume buick and other gm v6 will be the same

                Comment

                Working...
                X