Announcement

Collapse
No announcement yet.

New Truck with Pro Flo 2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Truck with Pro Flo 2

    Sorry for the vague post but I just bought a 1990 Jeep Wagoneer with a Pro Flo 2 system installed. Truck starts fine but runs rich at startup and has a rough idle. Once it's warmed up, it runs like a top.

    If you pull out and happen to stall before it's totally warm, engine sometimes floods and I need to wait like 20 minutes before starting again.

    What's the protocol here with a system that you did not install and have no history on. Can start over establishing a baseline? I'm not that familiar with fuel injection systems but if I can "retune" and improve this, I would be glad to "reset" the system and begin over.

    Just wondering best options when you have no history.


  • #2
    If it is running fine hot, then all you need to do is take some fuel out of the warm up enrichment. I don't think that you need to reset everything if it runs well everywhere else. Try taking 10% out and see how that does.

    Comment


    • #3
      Has a wideband O2 sensor been added to the Pro-Flo system? Hard to quantify fuel tuning changes on the original narrowband O2 setup.

      Comment


      • #4
        dont mess with your tune yet
        dont change anything until you save a copy
        because you will probably find this was the best compromise to get the system running

        Comment

        Working...
        X